About ink trapping

When an offset printed document uses more than one ink on the same page, each ink must be printed in register (perfectly aligned) with any other inks that it abuts, so that there is no gap where the different inks meet. However, it’s impossible to ensure exact registration for every object on every sheet of paper running through a printing press, so misregistration of inks can occur. Misregistration causes an unintended gap between inks.

You can compensate for misregistration by slightly expanding one object so that it overlaps an object of a different color—a process known as trapping. By default, placing one ink over another knocks out, or removes, any inks underneath to prevent unwanted color mixing; but trapping requires that inks overprint, or print on top of each other, so that at least a partial overlap is achieved.

Misregistration with no trap (left) and with trap (right)

Most traps employ spreading—expanding a light object into a dark object. Because the darker of two adjacent colors defines the visible edge of the object or text, expanding the lighter color slightly into the darker color maintains the visual edge.
Trapping methods

Trap a document using any combination of methods, including the following:

- Use process colors that don’t need trapping.
- Overprint black.
- Manually overprint strokes or fills.
- Use Adobe InDesign CS3 built-in trapping or Adobe In-RIP Trapping.
- Trap imported graphics using the trapping features in the illustration programs in which they were created. Refer to the documentation for these applications.
  Choose a trapping solution that complements the color output workflow you’re using, such as Adobe PostScript or PDF.

Avoid the need for trapping by eliminating the possibility of misregistration in your use of color. Prevent misregistration by making sure that abutting process colors have common inks. For example, if you specify a dark purple stroke with a vivid red fill, they will both contain a significant percentage of magenta. The stroke’s and fill’s common magenta will print as a single area, so that if misregistration occurs in the other process inks, the magenta printing plate will make any resulting gap hard to see.
About automatic trapping

InDesign can trap color documents with its built-in trapping engine, and can also take advantage of the Adobe In-RIP Trapping engine available on Adobe PostScript output devices that support Adobe In-RIP Trapping.

Both trapping engines calculate adjustments to the edges of both type and graphics. They apply trapping techniques to different parts of a single object, even if text or an InDesign object overlaps several different background colors. Trapping adjustments are made automatically, and you can define trap presets to address the requirements of specific page ranges. You only see the effects of trapping on color separations generated by a trapping engine; you cannot see the results on-screen within InDesign.

The trapping engine detects contrasting color edges, and then creates traps based on the neutral densities (lightness or darkness) of abutting colors, in most cases by spreading lighter colors into adjacent darker colors. The trapping settings you specify in the Trap Presets panel modify the trapping engine’s results.

Take a survey
Traps are specified in the following applications:
Adobe Acrobat® InProduction™
Adobe InDesign™
Adobe PageMaker®

The Adobe Trapping Engine uses its display list trapping technology to apply traps during the interpretation process, but prior to rasterization.

Files are rasterized and color separated using PostScript 3 in-RIP separations.

Device specific trapped data is to the output device for imaging.

The Adobe Trapping Engine uses its display list trapping technology to apply traps during the interpretation process, but prior to rasterization.

Traps are specified in the following applications:
Adobe Acrobat® InProduction™
Adobe InDesign™
Adobe PageMaker®

Controls for traps may also be specified through a device-specific user interface.

Adobe PostScript® 3™ RIP with Adobe in-RIP Trapping

Device specific trapped data is to the output device for imaging.
Automatic trapping requirements

To trap documents using the InDesign built-in engine, you need a PPD that supports separations.

To trap documents using the Adobe In-RIP Trapping engine, you need the following software and hardware:

- An Adobe PostScript Level 2 or later output device that uses a RIP that supports Adobe In-RIP Trapping. To find out if a PostScript output device supports Adobe In-RIP Trapping, contact the manufacturer or your prepress service provider.
- A PPD (PostScript Printer Description) file for a printer that supports Adobe In-RIP Trapping. You must select this PPD when you install the printer.

Related Information

- About PPD files

Take a survey

Send me an e-mail when comments are added to this page | Comment Report


Add Comment
Differences between built-in trapping and Adobe In-RIP Trapping

**Composite color workflow** With built-in trapping, you can separate a document by using InDesign or in-RIP separations. To use Adobe In-RIP Trapping, you must use In-RIP separations.

**Trap widths** Built-in trapping limits trap widths to 4 points, regardless of the value you enter for the trap widths. For larger trap widths, use Adobe In-RIP Trapping.

**Vector EPS graphics** Built-in trapping cannot trap placed vector EPS graphics; Adobe In-RIP Trapping traps all imported graphics.

Take a survey
Trapping imported bitmap images

Built-in trapping can trap bitmap images, such as photographs, to text and graphics. Bitmap images must be saved using a purely pixel-based file format that supports the color requirements of commercial printing. PSD (Photoshop) and TIFF are the most appropriate formats for commercial printing jobs; before using other formats, consult with your prepress service provider.

If you’re using an Open Prepress Interface (OPI) server, verify that it creates for-position-only (FPO) images using TIFF or PSD formats. If the images are TIFF or PSD, it may be possible to use built-in trapping, as long as you don’t select any Omit For OPI options at output time. (Omit For OPI options are located in the Advanced section of the Print dialog box when a PostScript printer is targeted.)

Note: The behavior and precision of trapping within an OPI workflow depends on many factors, such as the downsampling method the OPI server uses to generate FPO images. For best results, consult with your OPI vendor for information about integrating Adobe trapping solutions with the vendor’s OPI server.

Send me an e-mail when comments are added to this page | Comment Report


Add Comment
Trapping imported vector graphics

Both Adobe In-RIP Trapping and built-in trapping can trap text and graphics created with InDesign tools, and placed vector PDF files. However, built-in trapping cannot trap placed vector EPS graphics.

The text, paths, and frames you create in InDesign won’t trap correctly if they overlap a frame containing a placed graphic that built-in trapping won’t trap, such as vector EPS graphics. (However, those objects will trap correctly with Adobe In-RIP Trapping.) You may be able to use built-in trapping with documents containing vector EPS graphics if you adjust the graphic’s frame. If the placed EPS graphic isn’t rectangular, try reshaping the frame closer to the graphic itself, and away from other objects. For example, you might choose Object > Clipping Path to fit the graphics frame more tightly around the graphic.

InDesign text and graphics that overlap placed EPS graphics (left) won’t trap correctly; to achieve good trapping, reshape the frame so that it doesn’t touch other objects (right).
Trapping text

Both the Adobe In-RIP and built-in trapping engines can trap text characters to other text and graphics. (Built-in trapping requires that the text and graphics are created with InDesign, and aren’t contained in imported graphics.) A text character overlapping different background colors traps accurately to all of the colors.

Adobe In-RIP Trapping can trap all types of fonts. In contrast, built-in trapping works best with Type 1, Open Type, and Multiple Master fonts only; using TrueType fonts may result in inconsistent traps. If your document must use TrueType fonts and you want to use built-in trapping, consider converting all TrueType text to outlines by selecting the text and choosing Type > Create Outlines. The text will become InDesign objects that trap reliably. Text can’t be edited after you convert it to outlines.

Send me an e-mail when comments are added to this page | Comment Report


Add Comment
Maximizing trapping performance

Whether you use Adobe In-RIP trapping or built-in trapping, you can save time by not processing pages that don’t need trapping, such as pages containing black text only. You can use trap presets to enable trapping only for the page ranges that require it.

The speed with which built-in trapping is accomplished depends on the speed of your computer system. If you’re trapping every page of a long document, use the fastest computer system you have. Built-in trapping also makes extensive use of your computer’s hard disk, so a fast hard disk and data bus will benefit the built-in trapping engine.

To maximize the time your computers are available for other tasks, consider using Adobe In-RIP Trapping, which processes all traps at the RIP, instead of at your computer.
Setting aside disk space for built-in trapping

To trap the edges of every color that requires trapping, the trapping engine creates a large number of paths that are used only by the output device (the paths are not stored in your document). While Adobe In-RIP Trapping processes and stores these additional paths at the RIP, built-in trapping uses your computer’s hard disk as a temporary storage area for these trap paths. Before you use built-in trapping, make available as much hard disk space as possible.

The amount of disk space you’ll need depends on a wide range of factors, so it isn’t possible to predict exactly what a particular trapping job will require. However, disk space requirements are most likely to increase when one or more of the following characteristics of your document increase:

- Number of pages included in trapping page ranges.
- Number of overlapping color objects.
- Number of images that need to be trapped.
- Amount of text that needs to be trapped.
- Resolution of final output.

If the processing of a job that uses built-in trapping is interrupted or exhausts your disk space, trapping data may be left behind on your hard disk. When necessary, you can exit the application, and then find and delete temporary data in the C:\Temp folder (Windows). In Mac OS, restart your computer.
Trapping color / Trapping documents and books

Trap a document or book

Do not change the default trapping settings unless you’ve consulted with your prepress service provider, and you understand how trapping options work in the context of your specific document and printing conditions.

When trapping multiple documents in a book, make sure that you assign any custom trap presets to page ranges within the individual documents of the book. You cannot assign trapping settings to an entire book at once. However, you can resolve conflicting presets in a document.

1. If necessary, create a trap preset with custom settings for your document and press conditions.
2. Assign the trap preset to a page range.
3. Choose File > Print to open the Print dialog box.
4. Select Output from the list on the left.
5. For Color, choose either Separations or In-RIP Separations, depending on whether you’re creating on-host or in-RIP separations.
6. For Trapping, choose one of the following options:
   - Application Built-In, to use the trapping engine included with InDesign.
   - Adobe In-RIP. This option works only when you target an output device that supports Adobe In-RIP Trapping.
7. If your prepress service provider recommends changing ink settings, click Ink Manager. Select an ink, set the options specified by your prepress service provider, and then click OK:
8. Continue specifying other print options, and then click Print to print your document.